CursedToast

Hi all,
I contacted YoYo Games about this as well, but I was hoping perhaps you guys would have an idea as well.

I purchased a ready made/rigged character off Itch from a seller. He was kind enough to downgrade the project to 3.7.94 for me (this is the version of Spine that GameMaker currently supports).

All works well in the downgraded editor, but my exported animations always return an "invalid JSON" error when I try to import them into GMS2.

Does anyone have any advice for what could be happening? Something in the JSON I could be looking for? An animation feature that might hang it up?

Thank you!
CursedToast
  • 記事: 2

Nate

Does the JSON load in the Skeleton Viewer? That uses spine-libgdx, which is the Spine Runtimes reference implementation. If it works there then it is likely it should work in all of the 3.7 Spine Runtimes, unless there was a bug when porting from spine-libgdx to the other languages/game toolkits. That is possible, but not super likely since the 3.7 runtimes are pretty mature. Assuming it is working in all the Spine Runtimes, then the only variable left is that there is a bug in GMS2 or how GMS2 uses the Spine Runtimes. The GameMaker guys integrated the Spine Runtimes, so I'm afraid only they can help you with that.
アバター
Nate

Nate
  • 記事: 9861

CursedToast

Hey Nate,
Yeah, it seems to load up okay in the Skeleton Viewer (3.7).

I have already contacted YoYo and sent them the downgraded Spine Project, hopefully they're able to figure out what the issue is then. Thank you!
CursedToast
  • 記事: 2

Nate

OK, I wish you the best of luck! I don't mean to just pawn you off on the GameMaker guys, but it does look most likely to be on their side. If it turns out differently, please let us know and we'll do what we can.
アバター
Nate

Nate
  • 記事: 9861


Return to Editor