Alfred

Hello!

I've only just started using Spine, so this may be a user error :derp: . However, I don't know how to resolve the following issue:

I export layers from Photoshop. I import them into Spine, add bones, create meshes and animate.
Sometimes I need to go back to Photoshop and edit a layer & this is where the problem occurs.
I add some pixels to the layer and overwrite the original layer in the „image“-folder with the updated one.
I then edit the mesh in Spine to make it fit the new shape. Once I exit the mesh creation mode, the shape of the mesh seems to stay the same and only the inside of the mesh (my image) gets distorted (I uncheck deform before modifying).
It seems to work fine when I delete the mesh and make a new one. But this can't be the solution as it'd mean I'd need to do everything all over again just because I've edited the image slightly.
(I've read the Spine User Guide about image resizing and it does not really matter whether I click „yes“ or „no“ when the pop up window about the texture coordinates appears).

I've attached an image to show what I mean. I use version 3.8.99 PRO. I hope you can help me with this.
添付ファイルを見るにはパーミッションが必要です
Alfred
  • 記事: 4

Nate

When you have Deform unchecked, you are only adjusting the texture coordinates (the location on the image that corresponds to each vertex), not the vertex positions. When you exit edit mode, the vertices are still in the positions they were in previously. See here:
Mesh attachments - Spine User Guide: Deformed

You can either adjust vertices with Deform checked or exit edit mode and click Reset (note this is different from Reset in edit mode).
アバター
Nate

Nate
  • 記事: 11409

Alfred

Both of your solutions work, Nate :yes: ! Thanks a lot for the explanation.
Alfred
  • 記事: 4


Return to Bugs