ccmy

どうしても解決方法がわからないのでこちらに書かせていただきます。

3.8.55以降でspineのウインドウサイズを最大化、またはモニターの端まで最大に広げた状態で閉じると、次に開くときランチャーの画面から進まなくなり、起動出来なくなってしまいます。
設定フォルダを消すとサイズの設定が消えるのでまた起動できます。毎回設定フォルダを消してサイズを調整し直すのは大変なので原因を教えていただきたいです。
また、3.7.xxでは発生しないです。

---

起動出来なくなる条件間違ってました。
ウインドウサイズは関係なく、メインディスプレイじゃないモニターでspineを表示している状態で閉じることで起動出来なくなるでした。

ちなみにモニターは4つ使っていて、3つ1920x1080のモニターと、3840x2160のモニター一つです。
ccmy
  • 記事: 3

Mario

ご迷惑おかけして申し訳ありません! Spineを実行しているオペレーティングシステムは何ですか?
Sorry for the trouble! What operating system are you running Spine on?
アバター
Mario

Mario
  • 記事: 2271

ccmy

返信ありがとうございます。OSはWindows 10 Proです。
ccmy
  • 記事: 3

Mario

抱歉! 您还可以将您的spine.log文件发送给我吗? 您可以按以下说明找到它:
Spine Troubleshooting

Sorry! Could you also send me your spine.log file? You can find it as described here:
Spine Troubleshooting
アバター
Mario

Mario
  • 記事: 2271

Nate

マリオが言ったように、 spine.logファイルは役に立ちます。 また、3.8.88をお試しください。役立つ可能性のある変更がいくつか加えられています。 ビデオハードウェアの最新のグラフィックスドライバーを実行していることを確認することもできます。
Your spine.log file would be helpful, as Mario mentioned. Also, please try 3.8.88, we have made some changes that may help. You could also make sure you are running the latest graphics drivers for your video hardware.

それでも問題が解決しない場合は、3.8.88で prefs.jsonファイルを編集して、 monitor値を -2に設定できます。 たとえば、ファイルをテキストエディターで開き、 monitor:0を見つけて、 monitor:-2に変更します。 この設定では、Spineは閉じられていたのと同じモニターで再度開くことを試みません。 私たちはむしろ問題を修正したいのですが、少なくともこの方法でSpineが実行されます。
If you still have the problem, in 3.8.88 you can edit your prefs.json file and set the monitor value to -2. For example, open the file in a text editor, find monitor:0, and change it to monitor:-2. With that setting Spine will not attempt to reopen on the same monitor it was closed on. We would rather fix the problem, but at least this way Spine will run for you.

お手数ですがごめんなさい!
Sorry for the trouble!
アバター
Nate

Nate
  • 記事: 9653

ccmy

対応ありがとうございます。とりあえずprefs.jsonファイルを編集して、monitor値を -2して対応します。
多分他の環境では再現性の少ないトラブルだと思いますし。
ccmy
  • 記事: 3


Return to 日本のSpine ユーザー