k-tanabe

Unityで「Full HD (1920x1080)」表示
カメラを「Projection:Orthographic」「Size:540」
の2D等倍表示に設定した状態で Spine のモデルを
等倍表示させたい場合はどのような設定が最適なのでしょうか?

Scale が 1 だと小さ過ぎて見えない状態になってしまいます。
k-tanabe
  • 記事: 4

Misaki

こんにちは!

スケルトンGameObjectのスケールが1の時にちょうど良いサイズで表示されるようにするには、SkeletonDataAssetのスケールを変更してください。SkeletonDataAssetのスケールは、SpineとUnityの単位の差を合わせるために、デフォルトでは0.01になっています。(Spineを標準的に使用する場合、1ユニット=1pxでエクスポートされますが、Unityでは通常1ユニットが1メートルに設定されています。そのため、100ピクセルがUnityでの1ユニットに相当するようにスケールが0.01に設定されています)
Inspector_SkeletonData_Scale.png


SkeletonDataAssetのスケールのデフォルト値を変更したい場合は、UnityのEdit - Preferences(MacではUnity - Preferences)からアクセスできるPreferencesウィンドウのSpineセクションにあります、Default SkeletonData Scaleの値を変更してください。
詳しくはspine-unityランタイムドキュメントの以下のセクションをご覧ください。
spine-unityランタイムドキュメント: Spine Preferences
添付ファイルを見るにはパーミッションが必要です
アバター
Misaki

Misaki
  • 記事: 1007

k-tanabe

その通りに設定してみた所、
Scale 1 で問題なく表示が出来ました。
お答え下さり、ありがとうございました。
大変、助かりました。
k-tanabe
  • 記事: 4

Misaki

解決したようで良かったです!
またご不明な点がありましたらお気軽にこのフォーラムにご投稿ください。
アバター
Misaki

Misaki
  • 記事: 1007


Return to 日本のSpine ユーザー