Nick

Instead of having a sprite pre-cut into pieces in PS, I used the same attachment and cut it into pieces by mesh for supporting multiple z-order for character to walk around. It looks lilke one of the attachment is reading an incorrect location. I remember I reported this issue before and is fixed long ago. Somehow it managed to make a come back.

In Editor
_Expect.png


In Unity:
_ImportUnity.png


Sample Project
IssueSample Project.7z


P.S. Updated to the latest Unity runtime during testing.
添付ファイルを見るにはパーミッションが必要です
Nick
  • 記事: 274

Harald

We are sorry for the troubles and thanks for reporting! Thank you for including a reproduction project straight away, we were able to reproduce the problem. We will get back to you as soon as we've figured out what's going wrong.
アバター
Harald

Harri
  • 記事: 3479

Nate

Sorry about that! We've fixed the problem in 4.0.58-beta.
アバター
Nate

Nate
  • 記事: 11409

Nick

Nate さんが書きました:Sorry about that! We've fixed the problem in 4.0.58-beta.
So the problem exists in editor export instead of of the Unity runtime?
Will the fix also be available to the non-beta version? I don't want to upgrade and do beta test at this moment.
Nick
  • 記事: 274

Nate

Yes, it appears to be an editor bug. The meshes were not being unioned correctly to create a new polygon that encompasses all the meshes. I'm afraid the fix is only in 4.0.58-beta and later versions, as we're no longer doing 3.8 releases and 4.0 is nearly ready to go non-beta.

If you are exporting from the command line, you could use specify -u 4.0.58-beta when packing your atlas.

FWIW, I don't think you'll see the bug in 3.8 if you use rectangular packing instead of polygon packing.
アバター
Nate

Nate
  • 記事: 11409

Nick

Do you mean I can export with command line using v4 but keep my project as v3.8?

The unity runtime github page mention
spine-unity works with data exported from Spine 3.8.xx.
Is there another Unity runtime for v4 export? or is text the just outdated? because I couldn't find any link to v4 runtime on the github page.

---

Ah, sorry, I just spotted that there is actually a version dropdown to change to 4.0 beta in GitHub. I was on page for 3.8
Nick
  • 記事: 274

Nate

Nick さんが書きました:Do you mean I can export with command line using v4 but keep my project as v3.8?
Yes, you can continue using the 3.8 editor and 3.8 runtimes, but use 4.0 to do the packing. You may need to check Legacy output in the 4.0 texture packer settings, which will output in the older (3.8 and below) atlas format.

If you move to the 4.0 editor (which has some amazing new features, but is still beta), then you'll need to also use the 4.0 runtimes.
アバター
Nate

Nate
  • 記事: 11409

Nick

Okey Thanks

---

The bug still exists in v4.0.60 beta.
I also tried the sample project on early 58, 59. Same result.
Nick
  • 記事: 274

Nate

Sorry, we got it fixed now in 4.0.61-beta. For sure this time!

It was quite... interesting to fix. We also fixed when there are 2 meshes that don't overlap. Eg if you were to delete the middle piece from your project, it will be packed like:
アバター
Nate

Nate
  • 記事: 11409

Nick

Thanks.
Hope there is no more export bug after this one.
Nick
  • 記事: 274

Nate

Yesssss, so do I!
アバター
Nate

Nate
  • 記事: 11409


Return to Bugs