trafcio

Hey,

I had some problems with the Unity Timeline package.
I've updated to 4.0.5, so most of them are gone, but there is still a minor one. The preview timeline option works differently in the editor and the play mode.

I am playing two identical blink animations in the same Timeline row. Both should look the same. I recorded 3 versions in one video.


1. 0:00 - 0:05 - Play animations in editor (Two blink animations in the same row) - WRONG (the character do not close eyes fully during second blink animation)
2. 0:20 - 0:25 - Play animations in play mode (Two blink animations in the same row) - RIGHT (both first and second animation look the same)
3. 0:52 - 0:58 - Play animations in editor (Two blink animations on the same track different row) - RIGHT (both first and second animation look the same)

Only in preview, it doesn't work. It is not crucial for us, because it works good in playmode, but I think that you were changing it recently in version (4.0.5), that is why I'm reporting.

Cheers.
アバター
trafcio
  • 記事: 23

Harald

Thanks for reporting. This is known behaviour, it's due to the nature how the Spine Timeline implementation is setting animations. It's documented here: spine-unity Runtime Documentation: Spine AnimationState Track.

Please especially note the following sections:
spine-unity documentation pages さんが書きました:Important Note: Currently it is required to order the timeline tracks with base track at the top and overlay tracks below, otherwise the Editor Preview will display incorrect results.
spine-unity documentation pages さんが書きました:Edit mode preview mixing may look different from Play Mode mixing. Please check in actual Play Mode to see the actual results. Please see the remark in the Spine AnimationState Track section on correct track ordering when previewing multiple overlaid tracks.
アバター
Harald

Harri
  • 記事: 3353

trafcio

Thanks!
アバター
trafcio
  • 記事: 23


Return to Bugs