taikeutoka

件名の通りで、
WEBMで背景透過にチェックを入れてエクスポートをしても背景が透明にならず、
背景が真っ黒になります。
皆さん、問題なく背景透過されているでしょうか?
Verは4.1.16です。
taikeutoka
  • 記事: 3

Mario

ご迷惑おかけして申し訳ありません。 WEBM ファイルの再生には何を使用していますか? エクスポート設定をスクリーンショットとして投稿していただけますか?
Sorry for the trouble. What are you using to playback the WEBM file? Could you post your export settings as a screenshot?
アバター
Mario

Mario
  • 記事: 3233

taikeutoka

エクスポートしたwebmをAfter Effectsに入れて動画化にしようとしています。
エクスポート設定はファイルを添付します。
添付ファイルを見るにはパーミッションが必要です
taikeutoka
  • 記事: 3

Mario

設定は正しく、エクスポートされたWEBMファイルにはアルファチャンネルが含まれているはずです。しかしながら、Adobe After EffectsはWEBMのアルファチャンネルを処理できません: https://community.adobe.com/t5/after-effects-discussions/infuriating-webm-alpha-channel-import-issue/m-p/12193790

Adobe After Effects は、SpineもエクスポートできるAVIとProResコーデックでアルファチャンネルを処理できるはずです。しかし残念ながら、ProResファイルは同等のWEBMファイルよりもはるかに大きくなります。恐れ入りますがこの問題は弊社では解決できません。AdobeはAfter Effectsでこれを修正する必要があります。

もう 1 つの方法は、アートアセットで使用されていない背景色を使用し、透過ではなくその背景色で WEBMをエクスポートすることです。 その後、After Effects でクロマキーを使用して背景色を削除できます。 理想的ではありませんが、それでも WEBMのサイズのメリットは得られます。

Your settings are correct and the export WEBM file will have an alpha channel in it. However, Adobe After Effects can not handle the alpha channel in WEBM: https://community.adobe.com/t5/after-effects-discussions/infuriating-webm-alpha-channel-import-issue/m-p/12193790

I believe Adobe After Effects does handle alpha channels with AVI and the ProRes codec, which Spine can also export to. Sadly, ProRes files are much larger than the equivalent WEBM file. I'm afraid we can not solve this issue on our end, Adobe has to fix this in After Effects.

The other alternative would be to use a background color that your art assets do not use, and export the WEBM with that background color instead of transparency. You can then use a chroma key in After Effects to remove the background color. Not ideal, but you still get the size benefits of WEBM.
アバター
Mario

Mario
  • 記事: 3233

taikeutoka

ありがとうございます、理解できました。
taikeutoka
  • 記事: 3


Return to 日本のSpine ユーザー