screamson25

I'm sorry if I created the theme in the wrong place. I'm asking for your help.
I play spine animation with this script https://github.com/EsotericSoftware/spine-runtimes/tree/3.6/spine-ts/widget.
It works great. But some animations have artifacts on playback. Temporarily it can be seen on this page http://mvs-web.ru/4/index.html.
The third and fifth animation is the same on different backgrounds. That's the problem with it.
Can you please tell me what you can do about it?
添付ファイルを見るにはパーミッションが必要です
screamson25
  • 記事: 3

Mario

Are you exporting your texture atlas using premultiplied alpha? If so, you have to tell the widget that you use premultiplied alpha as well using data-premultiplied-alpha="true".
アバター
Mario

Mario
  • 記事: 2230

screamson25

badlogic さんが書きました:Are you exporting your texture atlas using premultiplied alpha? If so, you have to tell the widget that you use premultiplied alpha as well using data-premultiplied-alpha="true".
Thank you so much for paying attention to my problem!

I added the corresponding parameter to div, but it had no effect. On the specified canvas page with the parameter last.
Maybe you have more ideas?

I get a PNG file from ktx using Mali Texture Compression Tool v4.3.0. I don't know how it converts texture.

Here is a link to the original texture file, perhaps this will help https://drive.google.com/file/d/1Ai782XseGFVODTU3g_jv1UFtMi6MktXu/view?usp=sharing.
screamson25
  • 記事: 3

Mario

Could you please try your example without the Mali Texture Compression? I'm afraid I'm currently away from my development machine, so I can't test myself.
アバター
Mario

Mario
  • 記事: 2230

screamson25

badlogic さんが書きました:Could you please try your example without the Mali Texture Compression? I'm afraid I'm currently away from my development machine, so I can't test myself.
The original image files are in ktx format, not png. I haven't found any other programs that can convert ktx to png, so I can't do without the Mali Texture.
Perhaps you can tell us the best converter .ktx->.png?
I'm sorry if my tone of response seems bad. My English is bad.

---

I found a solution to the problem. The problem was in Mali Texture. The program has crookedly converted files.
Now I use PicoPixel to convert ktx to tga, and from tga many converters to png. Now the animations are played back as they were meant to be!
@badlogic, thank you so much for the tip, you were right!
screamson25
  • 記事: 3

Mario

Terribly sorry for the super late reply! Glad you figured it out.
アバター
Mario

Mario
  • 記事: 2230


Return to Runtimes