o0olele

# 版本/version
  • 4.0-beta-trial

# 问题/problems
  • 在试图导入json数据到项目时报错,看日志似乎是在animation部分出错,json数据版本是3.5.可能是版本不兼容问题,但是有其他解决办法吗?

  • 吐槽
既然有日志,为啥日志输出不再详细一点?

  • log
请务必选择一个有效的骨架JSON或二进制文件。
[error] Error reading file: \public\test\char_291_aglina_boc_1.json
at s.Dzw._(_:156)
at s.BXs._(_:304)
at s.BXs.B(_:277)
at s.Hpk._(_:1033)
at s.BXs.C(_:271)
at s.gFb.B(_:379)
at s.iGE._(_:91)
at s.zGr._(_:28)
at s.tAm._(_:188)
at s.tAm._(_:158)
at com.badlogic.gdx.scenes.scene2d.ui.Button.B(_:125)
at s.VAm._(_:93)
at s.cTC._(_:88)
at s.tfC._(_:71)
at s.IgQ.B(_:355)
at s.LPT5.B(_:124)
at s.UYo._(_:67)
at s.nGi._(_:141)
at s.iUV.run(_:254)
<events>
Cause: s.zft: Error reading animation: Start
at s.pJq._(_:349)
at s.KeW._(_:118)
at s.Dzw._(_:148) ...
Cause: [npe] Cannot invoke "s.mSC._()" because the return value of "s.mSC._(int)" is null
at s.KeW._(_:150)
at s.pJq._(_:1013)
at s.pJq._(_:710)
at s.pJq._(_:347) ...
o0olele
  • 記事: 2

Mario

您必须将Spine Editor版本设置为.json文件的版本,才能将其导入。 例如。 您的.json文件是使用Spine 3.5创建的,因此您必须将Spine Editor版本设置为3.5.x。 导入.json文件后,您可以将项目另存为.spine文件,然后在Spine 4.0-beta中重新打开它。

You have to set the Spine Editor version to the version of the .json file for it to be imported. E.g. you .json file has been created with Spine 3.5, so you have to set your Spine Editor version to 3.5.x. Once you have imported the .json file, you can save the project as a .spine file and re-open it in Spine 4.0-beta.
アバター
Mario

Mario
  • 記事: 2730


Return to 中国Spine用户