you_291

いつもお世話になっております。

掲題の件につきまして、
spineファイルをpngでエクスポートしようとしたところ、
複数の透明画像が書き出され、アニメーションの連番画像で書き出されません。
添付の設定で書き出しを行っているのですが、何か間違っている部分はありますでしょうか?

jsonの書き出しでは正常にatlas.txt、.json、pngで書き出され、pngにも素材の画像が統合されているので、ファイルの作成方法は間違っていないと思うのですが、連番の画像で書き出そうとすると上記のような状態になるようです。

何か誤っていることがあればご教授頂けると助かります。
添付ファイルを見るにはパーミッションが必要です
you_291
  • 記事: 4

Misaki

こんにちは!

エクスポート設定には特に問題が無いように見えますので、各アタッチメントのエクスポートが無効になっている可能性があるかと思います。ツリービューでエクスポートのチェックが外れていないかご確認いただけますと幸いです。
エクスポート.png
添付ファイルを見るにはパーミッションが必要です
アバター
Misaki

Misaki
  • 記事: 1007

you_291

ご返信ありがとうございます。

お教えいただいた各アタッチメントのエクスポートを確認してみたのですが、
添付の様に全てチェック済みのようです。

他に原因となりそうな箇所はありますでしょうか?
添付ファイルを見るにはパーミッションが必要です
you_291
  • 記事: 4

Misaki

ご確認いただきありがとうございます。恐れ入りますがスクリーンショットだけで問題を確認することは難しいので、再現用のSpineプロジェクトをcontact@esotericsoftware.comまでメールにて送っていただけませんか?:
画像は全てダミーに差し替えたりスケルトンのほとんどの部分を削除して一部だけにしていただいて問題ありません。
お手数ですがよろしくお願いいたします。
アバター
Misaki

Misaki
  • 記事: 1007

you_291

ご確認ありがとうございます。

ご連絡いただいた
contact@esotericsoftware.com
こちらのアドレスにダミー画像に差し替えた該当のファイルを添付したメールを送りましたので、
ご確認のほど、よろしくお願いいたします。
you_291
  • 記事: 4

Misaki

再現用のSpineプロジェクトをお送りいただきありがとうございます!
問題の原因はrootボーンのスケールが、アニメーション中にX0 , Y0 になっていることです。
実はスケールが完全に0になってしまうと、スケルトンが表示されなくなってしまうことがあります。(今回はPNGエクスポートで発見されましたが、ゲームに実装する場合でも問題になることがあります)
回避策として、スケールを0に限りなく近い値、例えば0.001などに設定していただくと、正しくエクスポートされるようになるはずです。お手数ですがお試しいただけますと幸いです。
アバター
Misaki

Misaki
  • 記事: 1007

you_291

早々のご確認ありがとうございます。

お教えいただいた方法で、画像を正常に書きだせることを確認いたしました。
ありがとうございました!
you_291
  • 記事: 4

Misaki

無事書き出せたようで良かったです!
また何かご不明な点がございましたらお気軽にこのフォーラムにご投稿ください。
今後ともSpineをよろしくお願いいたします。
アバター
Misaki

Misaki
  • 記事: 1007


Return to 日本のSpine ユーザー