HBu

Hi,

the upgrade to 1.5.10 fails and Spine crashes. spine.log looks like this:

Spine Launcher 1.2.1-full
Licensed to: xxx
Mac OS X x86_64 10.8.4
Java 1.7.0-u6-unofficial Oracle Corporation
OpenJDK 64-Bit Server VM
Up to date: 1.5.10
Spine 1.5.10-full, JGLFW
ATI Technologies Inc.
AMD Radeon HD 6750M OpenGL Engine
2.1 ATI-1.8.18
Started.
java.lang.ArrayIndexOutOfBoundsException: 0
at aoj.a(SourceFile:739)
at aoj.a(SourceFile:651)
at qh.c(SourceFile:452)
at qh.a(SourceFile:303)
at qh.D(SourceFile:269)
at com.esotericsoftware.spine.editor.Editor.a(SourceFile:669)
at an.d(SourceFile:166)
at qg.d(SourceFile:147)
at ao.run(SourceFile:72)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:711)
at java.awt.EventQueue.access$000(EventQueue.java:104)
at java.awt.EventQueue$3.run(EventQueue.java:672)
at java.awt.EventQueue$3.run(EventQueue.java:670)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:681)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)

Best,
Holger

Edit: Fresh install works.
HBu
  • 記事: 5

Nate

I think this is the new project bug, fixed and will be uploaded soon.
アバター
Nate

Nate
  • 記事: 9642


Return to Bugs