leftboot

Hi, we have recently begun exporting our Spine animation to Gamemaker. After importing the json file, the animation appears but the images we are using appear blown up very large or zoomed in. We have tested this with Spine 2.1.27, 3.5, and 3.6. We have also tested this in GM 1.4.1763 and GM 2.1.1.1.58, both times they appear the same way.

Each image within the animation has a resolution of 1024x1024. We suspect this may be the problem but we are not sure. I've attached a sample image of the animation after it's been exported to GM. I've also uploaded a screenshot of our export settings.

Any help is appreciated, thanks!
添付ファイル
exportsettings.PNG
gmexportsample.PNG
leftboot
記事: 1

Erikari

Try deselecting "Strip whitespace X" and "Strip whitespace Y". A warning on export should have notified you that using this setting may cause meshes to be displayed incorrectly. If your images are meshes this is exactly what could happen. Ideally to avoid this you should have exported your images with the photoshop script so that there is no additional space around your images, if you've done so you don't need to strip anything (:
アバター
Erikari

Erikari
記事: 695


Return to Editor