hollietree

...or maybe I have done something weird with my rig.

Essentially I've set up a (quite complex) rig, which deals with multiple directions, meshes and skins.
I'm finding a problem when I'm animating a change in a mesh which is skin exclusive.

So for example, my skin A character is wearing dungarees, but the other characters are not.
With my dungarees, there are several different meshes per direction. I'll key the dungaree into the profile view, all works fine when I test it.
Then, if I got to another skin (skin B) and key something within that which is also skin exclusive (let's say a hair mesh), I'll often go back to skin A and the dungarees have reset to what they were at before. If I fix that dungaree, I'll go back to skin B and the hair mesh has returned back.

I've gone back many times, made sure everything was keyed etc. It seems to me that the keys for the new skin attachments are overwriting those of the old skin, and with that the data of particular parts. However, it doesn't seem to effect all the skin exclusive parts, confusingly.

This also happens if I turn off (in animation) a mesh, or if I animate a colour :(

Any solutions, is this a known bug?
Cheers!
Hollie
hollietree
  • 記事: 14

Erika

Hi Hollie!

Let me do the usual round of troubleshooting:

- Are you working with Auto Key active? If no, perhaps switching from one item to another is erasing your keys, cause they were never stored.

- Are the elements in question in the same slots? Do they share the same skin placeholders or are they in different ones? A skin placeholder that turns active will overwrite another of a different skin, because the different skin items should be placed in the same skin placeholder, and not in different ones.

- Because you are talking generically about resetting to the way they were before, are you perhaps talking about draw order keys? those are unique for the whole animation across all skins, so if you change the order of something and let's say it shares the same slot of another skin element that should be behind, perhaps you need to separate the two if one needs to be in the front and another in the back.

If these don't help you, I'm afraid I will need more information. You can send us the project to our private mail if you're concerned about NDAs, contact@esotericsoftware.com and you'll also need to list the reproduction steps to get the behavior to happen. But I hope it's one of the above instead!
アバター
Erika

Erikari
  • 記事: 2412

hollietree

Hi Erika!

1) Auto key is active, so handy haha

2) They are all in seperate slots, so I don't think that is the issue. It seems to be more with skin exclusive joints, skin exclusive slots and skin placeholders.

3) It isn't draw order keys, the actual skin placeholders are not keeping their properties even when keyed when switching between skins :(

The file is quite complex so hopefully you'll be able to find the issue, I'll have to talk to my boss concerning ndas tho!

Cheers!
Hollie
hollietree
  • 記事: 14

thinhnv1411

I also have a similar problem with skins.

For example, I want to make some fbf effect for Weapon skins. So I created 1 bone Eff_Set1 (Effect for Skin1) and 1 bone Eff_Set2 (Effect for Skin2) , both have parent bone is (Weapon). I drag those bone to 2 diffirent skins ( SKin 1 and Skin2).

I turn on off attachment as usual. I did animation for Skin1, its no problem. But when I did animation for Skin2. I turned back, and "on/off attachment key " of Skin 1 animation was not the same.

Also. Bones that I drag into Skin. In unity runtime its still visible in another skin.
thinhnv1411
  • 記事: 1

Erika

Thanks for the project and repro steps Hollie!
I could reproduce the described problem on it and I've opened an issue to track it here:
https://github.com/EsotericSoftware/spine-editor/issues/523

@thinhnv1411 the first problem you describe sounds indeed like Hollie's one! The second one may be different, could you describe in more detail what exactly are you doing?
アバター
Erika

Erikari
  • 記事: 2412


Return to Editor