heiccs

Hello,
After I downloaded the new Spine launcher on 5th February 2020,
this error keeps appearing.

Is anyone knows how to solve this?
添付ファイルを見るにはパーミッションが必要です
heiccs
  • 記事: 1

Nate

The launcher has the latest version of the script, which has had some minor improvements lately. I don't know which older version you were using, so it's hard to guess at the cause. Maybe you could email us your PSD file? contact@esotericsoftware.com Hopeful we see the same problem so we can fix it.

Or, if you are somewhat techy savvy :nerd:, you can debug it yourself. To do that, run Adobe ExtendScript Toolkit that should have come with Photoshop (it's probably in your Start menu, if on Windows). Open the PhotoshopToSpine.jsx file in that, choose Photoshop from the select box at the top, make sure you PSD is open in Photoshop, then press F5 to run the script as normal. When you click OK on the script dialog, it may stop in a function named rasterizeAll, this is normal so just press F5 again and the script will keep running. However, if it stops again, that is where the problem is. Please tell us the line number where it stopped and we can likely fix the problem with just that information.
アバター
Nate

Nate
  • 記事: 9471

Moetal

unknown.png
I am also having same issue. The script was working perfectly fine for me before. After I reinstalled Spine this morning, I was getting the same debug error as member heiccs.

I tried debugging it myself and maybe got a bit more info (added alert(e);), but I don't know what this means. I've attached the second alert for your reference. I don't think my file is the problem as it is just pixel arts, no smart objects/vector/text.
添付ファイルを見るにはパーミッションが必要です
Moetal
  • 記事: 3

Erika

Hello! I tried the PhotoshopToSpine script v4.8 on PhotoshopCS6 and it worked fine, could you please tell me what version are you using, and send also a test PSD to reproduce the problem to contact@esotericsoftware.com mentioning this forum thread please?
アバター
Erika

Erikari
  • 記事: 2300


Return to Bugs