Vadym

Hi. When I export an asset from spine to psd it makes quality lower than it was. I think i tried all types of export settings)) the best is with raw + multisampling 8x, but not the same. I guess it's not a bug, but it's a kind of that user should know. Maybe I do smthg wrong ect. Here example to try.
添付ファイルを見るにはパーミッションが必要です
Vadym
  • 記事: 41

Nate

When you do an export, Spine is applying bone transforms and rendering the skeleton images to a buffer, then writing the result to an image file. There are a number of things that can happen during that process which can affect the quality compared to the source images.

For example, if a bone is rotated, the original image pixels won't match exactly with the pixels in the exported image. When that happens Spine does "filtering" where it samples the original image and outputs the best pixels it can, considering they don't match perfectly. When Linear filtering is enabled, multiple samples are used from the original image which produces a smoother exported image. You can try disabling it for a crisper exported image.

Even if you don't rotate, scale, or shear your images, if the image (or its parent bones) is translated so it is between pixels in the exported image, filtering has to happen. World coordinates in Spine map to pixels in the exported image, so if you place your image so its pixels are on integer world coordinates then there will be no filtering at all and the exported image will have the same quality as the original.

Keep in mind that when placing a region attachment in Spine, the position of the region attachment is the center of the image. If your image has odd dimensions, you would need to offset the position by 0.5 so the image pixels map 1:1 with the exported pixels. For example, an image that is 9x10 and placed at 10,10 will have filtering because it is centered at that position and the width is odd. Instead, you would need to place it at 9.5,10 or 10.5,10.
アバター
Nate

Nate
  • 記事: 9642

Søren

Here is an image illustrating what Nate mentions above.



1. Original image
2. Linear filtering disabled with a non-integer position.
3. Linear filtering enabled with a non-integer position.
4. Linear filtering enabled with an integer position of 0,0.

Due to the non-integer positioning in images 2 and 3 you see a small gap on the left canvas side which has translucent pixels.
アバター
Søren

Shiu
  • 記事: 2396

Vadym

Oh I see! Thank you for your answer!
Vadym
  • 記事: 41


Return to Editor